BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-28-2017, 05:24 PM
Junior Member
 
Join Date: Jan 2017
Location: Maryland
Car: Bmw M235xi
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default [F22] MOST bus audio enable help

I know most of you are more familiar with the E series but I need some help with my F22.

I am trying to install a moBridge DA3 which basically uses the MOST bus to output 8 RCA channels for external aftermarket amps. However, the F22 never got the upgraded amp that uses the MOST bus so the head unit outputs analog audio to the amp from the factory. To use the DA3 i will need to code my head unit ecu (and any others) to output audio over the MOST bus.

So far I FDL coded AMPLIFIER_VARIANT to "most" (from external) which sort of worked. Music from all types of sources (radio, bluetooth, ipod) stopped playing from the factory speakers/amp and the PDC beeps and system gongs started playing out of the DA3. For some reason the music audio was not playing out of the DA3 though.

Anyone know what I need to code to get the full audio output through the MOST bus?

For the 1 series it looks like all it takes is to code:

AUDIO_SYSTEM: hifi_system_harmankardon = 06 (this is my default)
AMPLIFIER_VARIANT: most = 02
EXTERNER_MOST: aktiv = 01 (also default for f22)

VO is set to 677

I got an error when I tried to VO 677 to my car. Something about not having the correct hardware so I stopped. Maybe it works if you continue?

Thanks for anyone's help in advance!


Reply With Quote
  #2  
Old 01-29-2017, 04:08 PM
Junior Member
 
Join Date: Jan 2017
Location: Maryland
Car: Bmw M235xi
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I figured it out for future reference. All that needs to be changed is the following:

AUDIO_SYSTEM: tophifi = 02
AMPLIFIER_VARIANT: most = 02

Not sure if AUDIO_SYSTEM even needs to be changed but that's what it was when it all worked.

Im assuming EXTERNER_MOST: aktiv = 01 needs to be true as well but that may be default for most people.

Hope this helps someone in the future from pouring many hours into research all over the place to figure this out! It seems so simple now...
Reply With Quote
Reply

Tags
da3, digital audio, mobridge, most bus

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mulf 2 USB enable on CCC iDrive Tweeder BMW coding and programming 2 06-29-2018 09:00 PM
GROM w/o audio signal - Redstar DSP amp w/o coax DSP connection drewski429 BMW coding and programming 0 01-19-2017 04:42 AM
Coding after install Alpine audio upgrade F30 ronald90630 BMW coding and programming 1 12-14-2016 01:47 PM
How to enable aux in on ccc modul? djshone BMW GT1, OPS/OPPS, INPA 3 02-14-2015 01:36 PM
enable highbeam DRL rvdweijer BMW coding and programming 0 05-09-2014 01:59 PM


All times are GMT. The time now is 10:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.