BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-26-2015, 10:43 PM
Junior Member
 
Join Date: May 2015
Location: UK
Car: E53 3.0 d
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default E53 EGS reprogramming WinKFP - downshift 2 to 1 issue

Hi

I am now really desperate for help on this. Car is having issue with downshift from 2 to 1 as it engages 1st gear only when stopped. It fills like nudge at the back. If in sport mode it does not do it. If I reset gearbox addaptions using INPA it is fine for a while then nudge is back.

I really need to sort this out before 3000 miles holiday this summer. Gearbox oil was changed together with filter. Guibo is fine too. The software on gearbox is till 2004 - when vehicle was manufactured. My last hope was to upgrade software. I've got cable which works with INPA but cannot get it working with WinKFP. Also, cannot find my assembly line number - 7549954.

If software fails I think next would be expensive torque converter.


Any advise please?


Reply With Quote
  #2  
Old 05-29-2015, 08:09 AM
Junior Member
 
Join Date: May 2015
Location: UK
Car: E53 3.0 d
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default sorted

OK, I will answer my own question. I've upgraded WinKFP to SP daten 53. The tricky bit which nobody seems to be mentioning is that instead of BMW-FAST for e53 and older versions of BMW you have to select KWP2000* protocol. Gearbox software updated OK


Hope this helps somebody. Thanks if it does
Reply With Quote
  #3  
Old 11-13-2015, 12:38 AM
Junior Member
 
Join Date: Nov 2015
Location: Brazil
Car: 2005 BMW X5 3.0i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello, I have faced similar issue with my 2005 X5 3.0i, with GM gear box. After reset is everything fine, but after about 5 km I have the "Trans. Fail Safe Program" on the cluster followed by jerks between shift. Stronger reducing from 4 to 3.
All the modules has already been updated.

Do you think that could it be a DME problem?

Thank you for your help...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW E60 530d CAS/Key Issue dj_wymo BMW coding and programming 3 12-11-2015 12:15 PM
BMW E60 530d CAS/Key Issue dj_wymo BMW Programmers 4 12-11-2015 12:08 PM
Progman issue Jimmy84 BMW diagnostics and repair 5 07-13-2013 02:14 PM
e-sys 3.20 coding issue - help appreciated. Painkiller BMW coding and programming 2 02-08-2013 07:04 AM
E90 Key reprogramming... Ac1d_Ra1n BMW Programmers 3 12-30-2011 09:34 PM


All times are GMT. The time now is 03:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.