BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming

Like Tree1Likes
  • 1 Post By lalaura
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2015, 07:54 PM
Junior Member
 
Join Date: Dec 2015
Location: London
Car: 320d E90 LCI
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default FRM3 possibly bricked??

Hi All,

Looking for some help:

I have successfully coded my e90 lci 2011 on a few occasion using Ncsexpert.
So far all good, except today.

While coding some basic light options and DRL brightness on FRM-NFRM module, after coding was accept, red service light pop us and all electronics dead.
Car starts but nothing works.

I tried flashing the FRM back to standard, but all I'm getting is no communication to ecu, error code 2020.

Error in CABD. no answer from ecu, Vin Faulty

I can connect to CAS, but I cannot read FRM whatsoever. NO sure what went wrong, I guess the brightness on DRL option must have somehow upset the FRM module.

Any ideas please?

Thanks in advance!

PS: just to update, I have since tried a different FRM module from a similar car and it works fine in my car, so I can rule out fuses, cables. etc.

I need to figure out how can I establish a connection with my old FRM so I can coded it to default.

Last edited by Evo400; 12-06-2015 at 09:46 PM.


Reply With Quote
  #2  
Old 12-19-2015, 05:48 PM
Junior Member
 
Join Date: Jan 2012
Location: France
Car: X3 E83 3.0d/W204 C320 4MATIC
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello,

no idea ?

I've the same problem with E87 2011 > All lights are off

After a lot of coding, it's the first time...

Please help us
__________________
X3 E83 3.0d / W204 C320 4MATIC
Reply With Quote
  #3  
Old 12-19-2015, 05:56 PM
Junior Member
 
Join Date: Dec 2015
Location: London
Car: 320d E90 LCI
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

I dont have good news for you I'm afraid.

I had to buy a second hand FRM from scrapyard and get it re-coded and all works as before!

The new FRM will work straight away when you first plug it in,and you can code later just to get you back on the road.

I cannot figure out what went wrong with mine, but I suspect if the voltage issue and if volts drop below 12v the FRM will go to sleep mid coding and bang, corrupt data.

If you know someone with Xprog eprom reader, they can erase the eprom and flash the original data back onto it, but this is loads of hassles

Hope this helps
Reply With Quote
  #4  
Old 12-19-2015, 06:57 PM
Junior Member
 
Join Date: Jan 2012
Location: France
Car: X3 E83 3.0d/W204 C320 4MATIC
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi, thx for the quick response.

Have you tried WinKFP ?
__________________
X3 E83 3.0d / W204 C320 4MATIC
Reply With Quote
  #5  
Old 12-22-2015, 10:25 AM
Junior Member
 
Join Date: Dec 2015
Location: London
Car: 320d E90 LCI
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, no response from ECU.

I think when the FRM bricks, it can no longer establish the connection with ecu so no other BMW software will help
Reply With Quote
  #6  
Old 09-22-2016, 07:49 AM
Member
 
Join Date: Jul 2015
Location: L.A.
Car: BMW
Posts: 44
Thanks: 0
Thanked 7 Times in 6 Posts
Default

Repair bricked FRM3 by Xprog, UPA, R270, Orange5:
[Only for registered users... ]

wish this helps someone
Vojno likes this.
Reply With Quote
The Following User Says Thank You to lalaura For This Useful Post:
Sean Mc (09-24-2016)
  #7  
Old 09-30-2016, 07:37 PM
Member
 
Join Date: Aug 2016
Location: Belgium
Car: 320d e90
Posts: 47
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I've coded allot of times below 12v, it does not go into sleep mode.

You just didn't have good luck and bricked it. :)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW E90 Carly for BMW bricked my FRM module XK8guy 3-er 6 12-01-2018 02:27 PM
BMW E87 FRM1 to FRM3 problem.. need help! bjorneoen BMW coding and programming 11 03-24-2017 07:55 AM
Frm3 retrofit and heated mirrors Dtype BMW diagnostics and repair 2 11-12-2015 11:29 PM
Progman Bricked my CAS2 on E60 s_cowen BMW coding and programming 4 02-02-2015 09:57 AM


All times are GMT. The time now is 05:13 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.