BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-10-2012, 06:47 PM
Junior Member
 
Join Date: Jun 2012
Location: Los Angeles
Car: 2011 MINI R56 Cooper S
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Getting Started on a 2011 MINI R56 S

I've been trying for about a month to get this up and running but am still getting the same error. At this point I think it may be my cable.

I've searched every thread on this site as well as NAM and bmwcoding.com and I'm at a loss.


Can anyone tell me if they have NCSExpert up and running on a 2011+ R56 what versions of everything they are using? And maybe what cable you have? I understand this one is a popular choice but the site says it only works up to 2010.


Currently running:
EDIBAS: 7.0.2
INPA: 5.00
NCSExpert: 3.1.0
Datens: V46.3

Or if there is anyone in the Los Angeles area who can help out in person that'd be amazing!

Thanks guys!


Reply With Quote
  #2  
Old 06-23-2012, 05:26 PM
Junior Member
 
Join Date: Jun 2012
Location: Los Angeles
Car: 2011 MINI R56 Cooper S
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So I posted a week or so ago and was suggested a new cable.

After getting the new cable, the first attempt to communicate with NCSExpert was slightly better. The program read the VIN but afterwards brought up the error below:


Every attempt after this resulted in the error below:


I get these errors wether I have the included adapter on the cable or not.

The cable is the recommended one.
INPA: V5.0.6
NCS-Expert: V3.1.0
EDIBAS: V7.2.0
DATENS: V46.3
Revtor's NCS Profile
Setup instructions I found [Only for registered users... ].
Cable is set to port 4 and 1 for latency, while setting up BMW Tools, I selected port 4.

Any recommendations?

Also, I thought I saw somewhere that somebody was providing free coding via remote desktop and irc. Does anyone know about this?


EDIT:
I just tried again. The only change I made was to add the daten files into a folder named "R56" inside the datens folder on the C drive. I did this and the computer read the car and actually processed the ECU and gave me a FSW_PSW file. I turned the ignition off, in accordance with the instructions, then when trying to connect for a second time in a row to write to the car I, again get the "VIN Faulty" errors.

I did every combination of changing files, uninstalling everything and reinstalling, restarting the computer, EVERYTHING! Absolutely nothing allowed me to reconnect to the car :( This is so frustrating.
Reply With Quote
  #3  
Old 07-01-2012, 04:24 AM
Junior Member
 
Join Date: Jun 2012
Location: Los Angeles
Car: 2011 MINI R56 Cooper S
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not sure what that is. Can you elaborate?


Also, so I setup bootcamp on my MacBook Air with XP SP3 and set everything up exactly as the instructions mentioned above advise. I used BMW Tools 5.0 and datens V46.3.

On the very first attempt to read and code everything was perfect, the car read perfectly, and it wrote to the .MAN file. But part way through, the car lost connection and when I tried to click, I received the "no answer from ECU" error above. Every further attempt to communicate with the car completely failed and I received the error when trying to read the VIN for the first time.

INPA still reads battery and ignition but NCS Expert has nothing.


Why is this working perfectly the very first time I try it and then dying part way through then never working again!?! It's all just making me unbelievably angry.

Everything HAS to be set up correctly, otherwise I'd never even get it to connect the first time. All of my software HAS to be compatible, otherwise I'd never get it to connect the first time. The computer and car HAVE to be compatible, otherwise I'd never get it to connect the first time. Is there some file that gets created that needs to be deleted every time NCS tries to communicate with the car?

I did notice that when running the laden.bat file most of the commands were giving errors such as "Cannot overwrite file with same name" but I do notice 5 or 6 new files created in the datens folder after running the laden.bat file.
Reply With Quote
  #4  
Old 08-07-2012, 01:25 PM
Junior Member
 
Join Date: Feb 2012
Location: Rochester NY/NORTHERN NJ
Car: E46 Coupe
Posts: 15
Thanks: 1
Thanked 3 Times in 3 Posts
Default

1) You may want to go back through and rewrite those files manually and not with laden.bat.

2) I've used V45 datens on R56's with no issues.

3) Since you are running bootcamp, you may have to manually connect your cable when you're in XP mode (basically find the setting that will detect the cable).
Reply With Quote
The Following User Says Thank You to TRIPLE_O For This Useful Post:
justawatcher (09-12-2012)
  #5  
Old 09-12-2012, 01:31 AM
Junior Member
 
Join Date: Sep 2012
Location: Texas
Car: Mini R50
Posts: 7
Thanks: 10
Thanked 0 Times in 0 Posts
Default My R50 had a similar issue//

the fix for me was to change the port and edit the appropriate files and settings and be sure to a full reboot, my cable didn't like port 4 and the cable came back up.
and to regain access to the car I had to disconnect and reconnect the battery... after that everything was peaches..

I had lost control of the sunroof until then as well.. wasn't even doing any thing special when the cable failed the connection. haven't had a problem since and the connection is faster.;)

Hope it helps/
Reply With Quote
  #6  
Old 09-20-2012, 01:10 AM
Junior Member
 
Join Date: Sep 2012
Location: http://www.easydvdmart.com/
Car: bmw
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

You may want to go back through and rewrite those files manually and not with laden.bat.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
BMW & MINI ETK, TIS, ЕТМ, WDS, KSD, DIS, EBA e.t.c. Admin Instructions, user manuals 13 09-17-2017 12:46 PM
Replace 2009 E60 CIC with a 2011 F10 CIC ViperRunner BMW diagnostics and repair 1 06-06-2012 08:07 PM
Bmw ksd 10.2011 max72 New Members Area 0 01-06-2012 11:47 AM
add mini to isis TSTE1982 BMW ISIS, ICOM A+B+C, Esys 2 12-02-2011 07:00 AM
n00b area - i.e. "Getting Started" forum Joe Forum Suggestions 8 11-16-2011 04:17 PM


All times are GMT. The time now is 10:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.