BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-18-2012, 09:55 AM
Banned
 
Join Date: Sep 2012
Location: USA
Car: BMW 7
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help!!!

Hi all,

I've got a BMW X3 and had the engine light come on recently so took it in to the garage for diagnositcs. And they used a tool named Fcar-F3-W,I searched it in the internet and found it . But I don't know how about it.

Originally it returned four codes but they were not sure is these were old or new codes so reset the computer and told me to come back when the light came back on to see what was there. This happened so duly went back to the garage.

They returned the following codes:

P0401

P0400

P1351

There advice at this stage was that it must be the EGR valve and it would need replacing. I know these models can suffer from a sticky EGR value so I asked to have it cleaned and they said this wouldn't be worth it and it would be best to replace the unit. They also said that 'we can't confirm this will fix the problem so there might be more work needed after this' - not inspiring confidence at this point!

I should say that the light is intermittent - some days it's there others it's not. when it is there it's a solid light and accompanied by three beeps to let me know there's a problem.

I also have the following to note on the car (which may have nothing to do with this issue but who knows?) ... When I reverse the car I get a combination of six beeps (standard I believe when selecting reverse) but sometime this gives me three short beeps and then starts to sound like reversing sensors until I get the flat line noise - considering I don't have parking sensors this really confuses me!!!

There is also a metallic rattling when the engine warms up which I think is coming from the exhaust (loose fitting perhaps?) from low revs up to about 1500rpm in the lower gears and then comes back after about 3/3500 rpm.

I don't just want to throw 200 at the problem on the garages say so when it might not do any good at all. Can anyone help with ideas or suggestions as to how to fault find the real issue and not just replace parts?

I've had the car about two months and it's covered 55k. Has a warranty with Warranty Wise but they don't want to know.

Thanks in advance,


Reply With Quote
  #2  
Old 09-20-2012, 01:30 AM
Banned
 
Join Date: Sep 2012
Location: USA
Car: BMW 7
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

is there anybody can help me?
Reply With Quote
  #3  
Old 09-25-2012, 08:41 AM
Banned
 
Join Date: Sep 2012
Location: USA
Car: BMW 7
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

help me please
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 03:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.