BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-03-2015, 10:34 PM
Junior Member
 
Join Date: May 2015
Location: Germany
Car: BMW 118i
Posts: 5
Thanks: 2
Thanked 1 Time in 1 Post
Question ISTA-D not registered

Hey Guys,

I've installed ISTA-D and ISTA-P like described in this video Tutorial: [Only for registered users... ]

ISTA-P seems to work(via Loader) but ISTA-D won't.

If I open ISTA-D I'm getting the message
Code:
Attention - This device has not been registered
If I change the following line from "true" to "false"
Code:
<add key="BMW.Rheingold.CoreFramework.ILeanActive" value="false"/>
I get an other window than the not registered:
Code:
License warning!
Unfortunately your local copy is not activated yet or has expired. It's necessary to activate your local installation via an authenticated license. Please follow the steps in the next dialogs.
If I continue there are fields for Name / E-Mail / Comment, after that it shows an key, which should be sent via mail to them. Below there is an field for a license. I also copied the license from an other and earlier version(3.44.30 which seems to be update only) in this field but still can't click on the next button which is greyed out.

The ISPI Admin Client shows all installed.
Code:
ISPI Admin Client: 1.1.808.3
ISTA: 3.48.20.13322
ISTA/P: 3.55.0.300
HDD-Update: 2.2.5449.17449
KSD: 2014.12.1.0
After I've read it never would activate in a VMware VM I've installed it on a physical machine but same problem there.

I don't know if you need any more information, here are my system informations:
Windows 7 x86 in VM, x64 physical, 4GB RAM, 180+ HDD, .NET Framework 4.5, newest Flash / Shockwave (...), "ISTA_SYS_3.48.20.13322.msi"

Greetings from Bavaria in Germany

firepower2k11


Reply With Quote
The Following User Says Thank You to firepower2k11 For This Useful Post:
rosenparushev (08-25-2015)
  #2  
Old 05-04-2015, 12:45 PM
Member
 
Join Date: Jun 2011
Location: NL
Car: E46-330Ci
Posts: 37
Thanks: 0
Thanked 20 Times in 10 Posts
Default

The only thing you need to do is run the "ID.reg" file so it will add some info to the registry. After this, ISTA/D should work fine!

Get the file from here, unpack it and double click it.
Attached Files
File Type: rar ID.rar (273 Bytes, 2523 views)
Reply With Quote
The Following 9 Users Say Thank You to BMR-E46 For This Useful Post:
ark28 (01-03-2016), Buio service (06-21-2015), chadderz (06-02-2015), firepower2k11 (05-04-2015), kixkur (06-01-2017), Plexidrax (11-01-2017), Rdodds033 (06-12-2015), rosenparushev (08-25-2015), turboduck (06-03-2017)
  #3  
Old 05-04-2015, 08:34 PM
Junior Member
 
Join Date: May 2015
Location: Germany
Car: BMW 118i
Posts: 5
Thanks: 2
Thanked 1 Time in 1 Post
Default

I was about a week working on get it running, installed it >15 times with different versions or VM / physical and this file was all what was missing...

And now my hero is there - thank you very much BMR-E46, it's working now!!!

Oh and by the way: it's now also working in Oracle VirtualBox

Greetings from Bavaria,
firepower2k11
Reply With Quote
  #4  
Old 06-02-2015, 06:15 PM
Junior Member
 
Join Date: Jun 2015
Location: UK
Car: E39 M5 840 Sport, E53 X5
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by BMR-E46 View Post
The only thing you need to do is run the "ID.reg" file so it will add some info to the registry. After this, ISTA/D should work fine!

Get the file from here, unpack it and double click it.
You Sir are a star. :)
Reply With Quote
  #5  
Old 06-02-2015, 09:53 PM
Member
 
Join Date: Jun 2011
Location: NL
Car: E46-330Ci
Posts: 37
Thanks: 0
Thanked 20 Times in 10 Posts
Default

Thanks for confirming that it's working
Reply With Quote
The Following User Says Thank You to BMR-E46 For This Useful Post:
dytechpcp (12-07-2015)
  #6  
Old 08-18-2015, 12:20 PM
Junior Member
 
Join Date: Aug 2015
Location: italy
Car: bmw e63
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thx, you saved my live. Worked! bmw next device is not registered
Reply With Quote
  #7  
Old 08-30-2015, 11:23 AM
Junior Member
 
Join Date: Aug 2014
Location: Porto
Car: 116d
Posts: 1
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry for asking but do you have the same resultes on the VM ?
I'm having the same problem but i only uso VM (i'm a mac user).
Reply With Quote
  #8  
Old 10-28-2015, 08:50 AM
Junior Member
 
Join Date: Oct 2015
Location: so cal
Car: 650i
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, just wanted to post this in case it helps anybody. I was having the same problem getting ista-d to load, kept giving a license error, and I had already run all the registry files. But ista-p worked fine. Finally figured out it was simply because I had transferred files from the ispi folder into the wrong location. Instead of program files folder, they are supposed to go into programdata folder. Once i figured that out it started right up.
Reply With Quote
  #9  
Old 11-01-2015, 06:29 PM
Junior Member
 
Join Date: Nov 2015
Location: chicago
Car: bmw
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey everyone i downloaded the Id.reg file tried all off the above and im still getting this massage
Device Has to be Registered
Reply With Quote
  #10  
Old 05-24-2016, 08:12 PM
Junior Member
 
Join Date: May 2015
Location: Germany
Car: BMW 118i
Posts: 5
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Impac4000 View Post
Hey everyone i downloaded the Id.reg file tried all off the above and im still getting this massage
Device Has to be Registered
Did you change the harddrive ID?
Also you should do all installation without internet connection.

@Werewolf_X
Yes, I only use it as an VM.
Works both VMware and Virtualbox.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding printing support to ISTA/P ISTA/D native install ejs BMW ISIS, ICOM A+B+C, Esys 10 11-20-2015 11:02 PM
Change ICOM mac address of registered icom in isid/vm interested BMW ISIS, ICOM A+B+C, Esys 5 07-17-2014 12:14 PM
Bmw isid native install (ista/d + ista/p) Admin BMW ISIS, ICOM A+B+C, Esys 15 07-16-2014 02:15 AM
request - HOW update ista P and ista D? slaw1971 BMW ISIS, ICOM A+B+C, Esys 0 11-13-2013 09:25 PM
BMW ISID 3.1 Native install on Lenovo ISTA-D 2.35 ISTA-P 2.48.2 Admin BMW ISIS, ICOM A+B+C, Esys 0 02-04-2013 11:30 PM


All times are GMT. The time now is 12:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.