BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-08-2016, 07:16 PM
QVS QVS is offline
Junior Member
 
Join Date: Nov 2016
Location: UK
Car: BMW E60
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default VIN Faulty Error in NCS Expert

Hi,

This is my first time posting on this forum!
I have used NCS expert to code digital speedometer on a 2005 BMW 5 series (E60), the coding worked successfully. However when I tried to do the same coding on a 2007 BMW 5 Series (E60) I get the error message 'VIN is Faulty COAPI-2020: ECU does not answer IFH-0009: No response from control unit CAS'.

I have checked the connections in INPA, and the two black dots for battery and ignition are black, which means it is reading the car fine.

The version of the software I am using are:
INPA - V5.0.6
NCS Expert - V4.0.1
Ediabas - v7.3.0

I have downloaded and updated to newer version of SP-DATAEN files v50.2, I have copied and replaced the files to C:\NCSEXPER\SGDAT and C:\NCSEXPER\E60\DATEN and finally to C:\EDIABAS\ECU, I have also run the LADEN file.

After doing all the above steps it still gives the ERROR 'VIN Faulty'.

I would appreciate any help with resolving these ERROR in NCS expert. If there are any newer versions of DATAEN files please let me know the link.

Look forward to any solutions.

Thanks
D


Reply With Quote
  #2  
Old 03-02-2017, 05:31 AM
Junior Member
 
Join Date: Dec 2016
Location: turkey
Car: 520i
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi QVS,

Have you got sokution for thia issue?
Reply With Quote
  #3  
Old 09-20-2017, 12:16 AM
Junior Member
 
Join Date: Apr 2017
Location: United States
Car: 535i
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Default Luck?

Same trouble...
Reply With Quote
  #4  
Old 09-20-2017, 06:14 AM
Junior Member
 
Join Date: Mar 2016
Location: bololandia
Car: 530 e60
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

you have tried removing the bridge between pins 7 and 8 on obd?

Enviado desde mi SM-J510FN mediante Tapatalk
Reply With Quote
  #5  
Old 06-25-2018, 04:15 PM
Junior Member
 
Join Date: Jul 2012
Location: france
Car: E91 330D 245hp
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Default

hi friends

i have same trouble on E70
is fresch install win7 32 and update daten
all seem ok but no way

anybody have way ?
Reply With Quote
  #6  
Old 06-26-2018, 07:30 AM
Member
 
Join Date: May 2013
Location: Czech Republic
Car: e34 540i
Posts: 41
Thanks: 10
Thanked 3 Times in 3 Posts
Default

I think problem is in cable. You need DCAN for cars after 2007, and turn Dcan on with application.
Reply With Quote
  #7  
Old 08-18-2018, 07:48 AM
Junior Member
 
Join Date: Aug 2018
Location: Seattle WA USA
Car: 2011 BMW X5M
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, anyone make progress resolving the issue as described by QVS. I just had the same issue (same tool versions as QVC also)....on a 2011 E70 X5M.
(SInce 2011 - D-Can was not bridged on pins 7 & 8)

Screen shot of Error report in NCS as follows:

Error in CABD! Look at CABD.ERR and ERROR.LOG

COAPI-2020: SG antwortet nicht IFH-0009: SG nicht angeschlossen oder meldet sich nicht CICR
COAPI-2020: SG antwortet nicht CODIERINDEX_LESEN
COAPI-2020: SG antwortet nicht IFH-0009: SG nicht angeschlossen oder meldet sich nicht CICR
COAPI-2020: SG antwortet nicht CODIERIN
Reply With Quote
  #8  
Old 08-26-2018, 12:56 AM
Junior Member
 
Join Date: Aug 2018
Location: Colorado
Car: 128i
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm experiencing something similar after accidentally writing junk code to my CAS module because of failing to delete the FSW_PSW.MAN file contents and/or failing to save the correct text file as the FSW_PSW.MAN before running the Code to CAS.

Fortunately my car still runs and drives as before, so I don't think the module is completely bricked. But I cannot connect to the CAS (or NFRM or any ECU after selecting E89 chassis). So there appears to be no way to code the car further, or reset the modules I "added" the bad code to.

I have checked my DCAN cable and settings. Windows xp laptop with the $100 onestop cable, set COM1 and Latency to 1, running FTDI 2.x.28 or most recent on their website.
Latest/final E89 daten. I even re-downloaded and installed it with bmw coding tool to be sure it's not messed up. I'm certain my programs are at least in 99% good shape.

I had connected to the car, changed the BC speedometer setting and coded that in. It's still there and working today. Since writing the junk onto CAS, I can no longer connect to the car only 30 seconds later with the identical cable, programs, settings. (I'll post the error log below).

[18:05:13.562] [2018-08-25] [SERIE] 2000 Error LFCDHDIA.CPP (A_PL2KMB.IPS/IPO) CDHapiResultText 1
[18:05:13.562] [2018-08-25] [SERIE] Error in EDIABAS or in ECU description file (SGBD) IFH-0018: Initialization error KOMB87

[18:05:13.562] [2018-08-25] [SERIE] 2000 Error COAPI2.CPP coapiRunCabd 6
[18:05:13.562] [2018-08-25] [SERIE] Error in EDIABAS or in ECU description file (SGBD) CODIERINDEX_LESEN

[18:05:13.562] [2018-08-25] [SERIE] 2000 Error COAPI.CPP coapiReadCodierIndexFromSg 5
[18:05:13.562] [2018-08-25] [SERIE] Error in EDIABAS or in ECU description file (SGBD) CODIERINDEX_LESEN: A_PL2KMB

[18:05:13.593] [2018-08-25] [SERIE] 4459 Trace CVT_PROC.C GetCvtFile 11
[18:05:13.593] [2018-08-25] [SERIE] CVT invalid (Job expression not present, no true job expression found) _Baureihe

[18:05:13.593] [2018-08-25] [SERIE] 1000 Error COAPI.CPP coapiGetFswPswFromAsw 2
[18:05:13.593] [2018-08-25] [SERIE] Error
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
NCS Expert Vin is faulty 64 bit Papote BMW GT1, OPS/OPPS, INPA 2 11-11-2015 09:54 AM
[E61] NCS Expert: Error in CABD! Look at CABI.err and ERROR.LOG. COAPI-1043... rathersmart BMW coding and programming 0 10-03-2014 08:57 PM
NCS Expert E53 Faulty Chassis joker79 BMW coding and programming 2 04-12-2014 04:46 PM
NCS Expert Chassis Faulty Error?? chrismvideo BMW coding and programming 1 01-24-2014 06:06 PM
FA_READ ERROR - NCS Expert nek BMW coding and programming 0 12-19-2011 08:52 PM


All times are GMT. The time now is 02:31 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.