BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-05-2016, 06:36 PM
Junior Member
 
Join Date: Mar 2016
Location: Kent UK
Car: E65 745i and E38 735i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default 745i E65 with Airbag issue .... 93CD SIM: Deactivation SSFA

Hello guys,

hope you can assist as I am running out of time :(

I need to get this sorted over the weekend, eitherwise I will not be able to drive the car coming Tuesday ... as it will fail the local test (MOT)

The problem is that the last couple of days when I was diagnosing the problems etc, I could erase the faults and the airbag / seatbelt light would go away... but it would come back on after a while...

The error code I cannot find explanation anywhere on the net I have attached the screen shot from the DIS.

I have removed the SSFA module and checked for any issues with soldering etc, everything looks great and pristine. Not problems there.

I scanned with the module disconnected and I can see that the SIM provides one extra error code that the module is missing. So this sorts this problem...

I have unplugged the seat belt plug from the SSFA and I am getting an extra error regarding the seat belt restraining system so this works as well. (well the SSFA at least ...
I have then unplugged the other plug and it says driver Airbags fault so that cable works as well....

I have checked the yellow fibre cable and it lights up red, so the line is not damaged.

When I tried to logon to the SSFA module via INPA is says something about versions do not match and if I want to continue...

NCS expert reads the module , but I have to use my not normal expert profile (EXPERT MAN) instead of (Revtor's NCS Expert Prrofile) in order to read it ... eitherwise is comes up with many errors?...



But once I load with the EXPERT Man profile all is good..


Cheers
Vasilis




Last edited by kent7; 03-05-2016 at 06:43 PM.


Reply With Quote
  #2  
Old 03-05-2016, 07:09 PM
Junior Member
 
Join Date: Mar 2016
Location: Kent UK
Car: E65 745i and E38 735i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have extracted the SSFA and SIM, TRC files if it is going to be any help? I have tried to disable things ... but to no result :(

I cannot understand the error code from the diagnostic as it is not listed anywhere ... on the web
Attached Files
File Type: txt SIM FSW_PSW.txt (4.3 KB, 16 views)
File Type: txt SSFA FSW_PSW.txt (674 Bytes, 7 views)
Reply With Quote
  #3  
Old 03-06-2016, 12:08 PM
Junior Member
 
Join Date: Mar 2016
Location: Kent UK
Car: E65 745i and E38 735i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok here is what I have done ... I have swapped the driver module to the passenger module, the plugs are unique ... but with a little mod managed to fit.
The result was the following I still had driver module error.

So the error followed the module... rather than now reporting passenger module error. So this rules out communication fault somewhere with the SIM unit.
Am I right thinking that?

When the driver module was plugged in the passenger side, I also got an extra error about driver airbag, which I am sure is the different in the coding parameters. Rather than a real fault.

By getting a used "good" SSFA will it be possible to program it in my car? or do I need to buy a new one? Anyone has some sort of experience?
Reply With Quote
  #4  
Old 03-06-2016, 07:04 PM
Junior Member
 
Join Date: Mar 2016
Location: Kent UK
Car: E65 745i and E38 735i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have just connected to the SIM with INPA and I got an extra error code.
This I could not / and still cannot see via DIS ... :( strange
After reading on the documentation about the E65 saftery system the SIM is disabling a Satellite module if something is stored as an error. So I assume when the error 93BC comes up, the module then is disabled.
Anyone knows that the 93BC is ?




Also when I try to enter the SSFA module via INPA I get the following errors


And the BMW part number will not appear properly


When I try to access the error memory I get some script errors and the following
Reply With Quote
  #5  
Old 03-10-2016, 09:06 AM
Junior Member
 
Join Date: Mar 2016
Location: Kent UK
Car: E65 745i and E38 735i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have received a good used SSFA module yesterday and I replaced it.
I can now see the part number and accerss the error memory properly.
However I need to change the VIN to my car and program it ... and then sort out the time etc...

The problem is my Tool32 and Winfkp do not recognize the ZB number..
well the tool32 comes back with coding errror or something :(
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ICOM voltage issue mii BMW ISIS, ICOM A+B+C, Esys 13 03-08-2017 11:19 AM
BMW E60 530d CAS/Key Issue dj_wymo BMW coding and programming 3 12-11-2015 12:15 PM
BMW E60 530d CAS/Key Issue dj_wymo BMW Programmers 4 12-11-2015 12:08 PM
BMW e90 Ipod connectivity issue Big Beaar DIY guides 0 07-24-2013 10:40 PM
Progman issue Jimmy84 BMW diagnostics and repair 5 07-13-2013 02:14 PM


All times are GMT. The time now is 10:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.