BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #11  
Old 02-05-2018, 10:14 PM
Junior Member
 
Join Date: Mar 2013
Location: Australia
Car: BMW E90 330i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had rough idle problems on my E90 330i sedan, happening randomly, diagnostics would not tell me anything, no faults appearing in ISTA. I had a leaking rocker cover gasket which I had been meaning to replace for some time, finally replaced it and the idle problem went away.

Watch out when you remove the crankcase ventilation hose from the back of the rocker cover (its hard up against the firewall), more than likely it will be brittle and probably break (I broke mine trying to get it off). Plan to budget for this hose when doing the job (its not cheap, not a common hose, about $130USD from ECStuning), I managed to temporarily fix my hose until a new one arrived.

Hope you fix your problem.
Reply With Quote
  #12  
Old 03-14-2018, 02:23 PM
n53 n53 is offline
Junior Member
 
Join Date: Jan 2018
Location: Portugal
Car: 2011 BMW 330i N53
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mdebelic View Post
I had rough idle problems on my E90 330i sedan, happening randomly, diagnostics would not tell me anything, no faults appearing in ISTA. I had a leaking rocker cover gasket which I had been meaning to replace for some time, finally replaced it and the idle problem went away.

Watch out when you remove the crankcase ventilation hose from the back of the rocker cover (its hard up against the firewall), more than likely it will be brittle and probably break (I broke mine trying to get it off). Plan to budget for this hose when doing the job (its not cheap, not a common hose, about $130USD from ECStuning), I managed to temporarily fix my hose until a new one arrived.

Hope you fix your problem.
How did you know that the rocker cover wasn't sealing? When I try to open the oil cap with the engine running, I feel strong vacuum, I assume it's sealing. Did you had a smoke test? If so, did you test it yourself?

Edit: I swapped VANOS solenoids, and I had good improvement of idling. I'll try to clean them the best I can, if it doesn't completely solve the problem, I'll just buy new ones.

Last edited by n53; 03-14-2018 at 02:27 PM.
Reply With Quote
  #13  
Old 05-22-2018, 02:14 AM
Junior Member
 
Join Date: Mar 2013
Location: Australia
Car: BMW E90 330i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by n53 View Post
How did you know that the rocker cover wasn't sealing? When I try to open the oil cap with the engine running, I feel strong vacuum, I assume it's sealing. Did you had a smoke test? If so, did you test it yourself?

Edit: I swapped VANOS solenoids, and I had good improvement of idling. I'll try to clean them the best I can, if it doesn't completely solve the problem, I'll just buy new ones.

If you have oil leaks from the rocker cover, you will have vacuum leaks.
Reply With Quote
  #14  
Old 12-01-2018, 01:56 PM
Junior Member
 
Join Date: Oct 2016
Location: France
Car: 330i e92
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by djrynyc View Post
Check the idle control valve ?

Sent from my SM-G935P using Tapatalk
As far as i know there isn't one on the N53, or at least not named ICV.

Quote:
Originally Posted by n53 View Post
Hello,

I have the same problem, and I have done some of what you did already aswell as other checks :

- Fixed leaking injectors
- Clean Vanos with brake cleaner
- Restart adaptations (flywheel included)
- Increase idle RPM with INPA
- Verify if DISA is working properly
- 6 new coils
- 6 new spark plugs
- Cleaned MAF with contact spray (heavily)
- Verify low and high pressure fuel during coldstart / and when stopped via INPA
- Verify/clean throttle body

Nothing I have done solved the problem. Idle is rough and everything gets worst when I press the clutch, but when warm, everything is fine again.

But, I have a 2AEC code (NOx sensor) sometimes.

I will do a verification as bimmerprofs.com says to do, to check if everything is fine with catalytic converter system.

Did you find the problem?

Has N53 an Idle control valve as djrynyc is suggesting?

i replied to djrynyc in the above section.
And no, i haven't found the issue.
Still have some nox sensor errors just like you.
Think i'll replace it someday, but i've gotten used to the idle issue (so sad saying it though).
This sensor is preetty expensive for a sensor, but yeah, ideal test situation would be to replace this one and the O2 sensors.
I think mdebelic is onto something regarding the cover gasket.
My cranckcase cover suffered of CCV valve issue and i managed to replace the valve only. Changed the huge gasket too. But still same idle problem.

Quote:
Originally Posted by mdebelic View Post
I had rough idle problems on my E90 330i sedan, happening randomly, diagnostics would not tell me anything, no faults appearing in ISTA. I had a leaking rocker cover gasket which I had been meaning to replace for some time, finally replaced it and the idle problem went away.

Watch out when you remove the crankcase ventilation hose from the back of the rocker cover (its hard up against the firewall), more than likely it will be brittle and probably break (I broke mine trying to get it off). Plan to budget for this hose when doing the job (its not cheap, not a common hose, about $130USD from ECStuning), I managed to temporarily fix my hose until a new one arrived.

Hope you fix your problem.
check my reply above. But yeah that my be a source of this issue.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
E90 330i cruise control retrofit DME Error pikuser5 BMW coding and programming 4 06-14-2018 09:04 PM
BMW E46 330i (2002+) Parking Light Delete e46330i BMW Programmers 2 04-20-2014 07:29 AM
COLD STARTS ( ROUGH IDLE) Please Help! joemicbur BMW diagnostics and repair 1 07-16-2013 01:24 PM
330I SOS Failure - Coding bandsareme BMW coding and programming 0 03-07-2013 09:51 PM
Rough runnin pooldaveb BMW diagnostics and repair 4 08-28-2012 05:22 AM


All times are GMT. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.