BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2014, 08:22 PM
Junior Member
 
Join Date: May 2014
Location: London
Car: Bmw 335i
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Dsc/brake lights are on help

Hi, I'm new to the forum and wanted to ask a question regarding my 2007 e93 BMW 335i MSport Convertible. Hope you can help.
Basically last week i was driving i hit a curb and 3 lights appeared on my dash. DSC light brake light both amber. Also tire pressure keeps popping up on IDrive even though there is enough pressure in the tires (32psi front and 38psi back) aswell as DSC. Also I've noticed my DTC button does not work therefore i have no traction and lastly my cruise control has also stopped working.

I decided to take the car to kwik fit to get 4 wheel alignment done. They were not able to do it because apparently lower control arm eccentric bolt does not turn to be able to align the wheel (rear passenger) the wheel is out by 100. I was told to replace the lower arm as i did and took it back and. Now they still having the same problem. What might you think the cause of this problem might be, and will this cause the lights to appear on dash?
I also noticed couple of days ago, the lights only come on with original wheels on because whilst the lights were on i put on a different set of alloys and the lights disappeared. After putting originals wheel back on the light appeared again 10miles into journey. Which is giving me doubt that it might be the wheel alignment however why is it the bolt is not turning enough?
Thank you.


Reply With Quote
  #2  
Old 07-16-2014, 12:58 AM
Junior Member
 
Join Date: Apr 2012
Location: Glasgow
Car: 2003 X5 3.0i E53
Posts: 6
Thanks: 9
Thanked 0 Times in 0 Posts
Default

could be the ABS sensor lead has been disconnected ??
or try another/new ABS sensor lead ??
or the brake wear sensor dislodged ??
Reply With Quote
  #3  
Old 08-17-2014, 08:45 PM
Junior Member
 
Join Date: Aug 2014
Location: USA
Car: BMW M5
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Get your ABS module rebuild, it fixed the issue for me
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Performance Brake Coding 525da_touring BMW coding and programming 0 03-17-2014 01:46 PM
adaptive brake ligths Speedy BMW GT1, OPS/OPPS, INPA 0 01-19-2014 06:46 PM
(ABS) and (ASC+T)(DSC) lights Andrew318ci BMW diagnostics and repair 1 05-30-2013 07:36 AM
Diagnosing Cause of DSC, Red BRAKE & ABS lights jonwrong BMW diagnostics and repair 4 12-02-2012 02:59 PM
BMW E46 Front Brake & Rotor Change Admin 3-er 0 06-13-2011 04:49 PM


All times are GMT. The time now is 06:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.