BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-21-2017, 05:25 PM
Junior Member
 
Join Date: Apr 2017
Location: Detroit
Car: 06 BMW M5
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default E60 M5 CCC: No sound, no bluetooth, no EDC

Hi. I am having an issue with my E60 M5's CCC. I posted this on M5Board, but thought that I may get a little more exposure on this site regarding this specific issue.

Bluetooth wouldn't pair a phone (it would connect and show the phone in iDrive, but then delete it within a second or two).
Also, I couldn't edit anything in the MDrive - Anything that I would try to change, would revert back to what it was within about a second.
I ran DIS to see if it could see anything, and it noticed some coding faults in the gateway. I flashed the GW module with KDCan (on K) with WinKFP, and was successful - However, it did not fix the issues above.
I decided to flash the entire CCC the same way, and what I didn't realize is that it was going to take about 7 hours. It got to 100%, then error and brick. Biggest waste of 7 hours ever, considering I monitored the voltage the whole time.
I contacted Bimmergeeks to see if they had a solution with their cable, and they explained that they wouldn't recommend any KDCan on the MOST flashes (which theirs is). However, they suggested either ICOM (my last resort before dealership or new CCC), or CD CCC Recovery Disc - which I was not familiar with. They explained the files, and I burned the correct disc for my CCC hardware (9.5).
Popped the disc in, and in about 1 hour and a half, I was back in business.

Now the current status -
- MDrive is editable, however the EDC line is missing.
- Bluetooth menus look more normal, however the "enable bluetooth" is grayed out, so bluetooth is still not functional. Possible MULF module issue?
- No sound at all from speakers - No radio, chime, nothing...

I checked all the fuses, and pulled negative battery cable for a while, however no change. I was going to hook it up to DIS to see if it can see any faults - however, if anyone has any suggestions on how to resolve this, I'd love to hear it.

Thanks!


Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio, cd, not selectable also no sound '03 e39 Milan BMW diagnostics and repair 1 01-09-2017 09:57 PM
Sound of CCC not going to max after coding hifi? BIMCoded BMW coding and programming 3 08-11-2016 10:49 AM
E60 Remove reverse gong sound Mikke BMW coding and programming 3 03-03-2016 02:21 AM
Bmw e92 reactivate bluetooth djollie BMW ISIS, ICOM A+B+C, Esys 0 07-15-2014 02:16 PM
Bluetooth? gleep BMW coding and programming 0 10-24-2012 11:26 AM


All times are GMT. The time now is 03:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.