BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-14-2014, 06:28 PM
Junior Member
 
Join Date: Oct 2014
Location: over the hills and far away
Car: e63 645
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default e63 645 cranks but wont start

i'll start off by saying im just about ready to torch this thing.

ive had so many electrical issues since ive bought it but this one has got me totally stumped.

i was driving home on sunday, slowing down for a roundabout when the i drive lit up with "transmission failure" and the red cog on the dash.

i was only a mile or two from home so i limped it back, whilst doing so, the rev counter was going nuts, swinging up and down, but the engine didnt sound like it was changing speed and it didnt seem to be changing gears.

i plugged my laptop in and using inpa, read "crankshaft sensor failure" from the engine and "4f86" and "51A7" from the gearbox.

after stopping the car as soon as i got home, it then wouldnt re start.

switch the ignition on and everything is fine, start cranking and you get the "transmission failure" on the i drive screen.


i removed the crank sensor and probed it with a multimeter, open circuit between any of the 3 pins. fair enough, maybe it failed from old age.

new one arrived today, so i swapped it made sure the connector was on the sensor nice and snug, all the pins in the connector were okay and not pushed back.


exactly the same problem. just sits there cranking and reading the errors from the engine gives the same crank sensor failure.

in the "status" tab on inpa, where you can see enigne rpm and stuff, theres no reading whilst cranking.


any ideas, how to continue trouble shooting or what to try next?


Reply With Quote
  #2  
Old 10-14-2014, 08:39 PM
Junior Member
 
Join Date: Oct 2014
Location: over the hills and far away
Car: e63 645
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

anyway, ive just been out. wiped all the codes from every module using inpa, and then cranked it until the gearbox error came back up.

the errors i get are;

dme: CDA7 / 277F

EGS : 51A7

DSC: 5F76

tomorrow im going to have a look in the box where the dme / ivm is, to make sure theres no dodgy wires. about 10 minutes before this happened i was driving down a very bumpy gravel drive with lots of potholes.
Reply With Quote
  #3  
Old 10-15-2014, 05:34 PM
Junior Member
 
Join Date: Oct 2014
Location: over the hills and far away
Car: e63 645
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

fixed it this morning.

number 5 fuse in the ivm was blown. (looked on wds and it appears to power the dme amongst other things) replaced that and it fired up first time.



so yeah, to recap, if your e63 cranks over but wont start and gives you a gearbox failure (red cog) and dsc/abs (triangle with exclamation mark and a curvy arrow spinning round it) errors, whip the passenger side (on a uk car) pollen filter out, the tray underneath it and the lid off the tupperware box that has all the ecu's and stuff inside, look for a big black plastic thing fitted vertically with wires going in the top and the bottom, it has 11 fuses in it. number 5 powers the dme and had blown in my case.

i know theres probably eleventy other different things that can cause the same warnings, but its one thing to try.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
e63 645 cranks but wont start gk73a BMW diagnostics and repair 0 10-14-2014 06:19 PM
AK90 Wont write key wesiby BMW Programmers 1 02-16-2014 05:34 PM
BMW E46 3.30d wont start nordin 3-er 0 09-12-2013 08:40 PM
Brand New key wont work? ggemen DIY guides 5 12-24-2012 02:42 AM
iNPA wont communicate with E60 2007 Garyk BMW GT1, OPS/OPPS, INPA 1 05-04-2012 07:56 PM


All times are GMT. The time now is 06:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.