BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-14-2019, 01:06 PM
Junior Member
 
Join Date: Feb 2019
Location: United Kingdom
Car: Bmw 320i E90
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help, Problems with BMW 320i

Hello,

Im having engine problems with my 320i e90 2009, i have to drive the car really slow with little throttle, if i try to pull away quicker or even try to climb up hill the bmw starts to jerk, that feels like the engine is dragging the car back, i get a clattering sound form the engine followed by a whistle, and finally a misfire, usually on cylinder 4.. I have to pull over and restart the car in order for the misfire to stop, i can then carry on, but again if i put my foot down it all comes back.

i have recently changed the coil packs and put new spark plugs in, aswell as replacing the 02 sensor before cat..

i have the following error codes:

2ECC - alternator communication intermittent
2EF7 - unknown fault
2D06 - mass air flow sesnsor intermittent
30c1 - oil pressure
29D0 - misfire Cylinder 4
29D9 - misfire detection
29F1 - fuel pressure easured plausibility error


Reply With Quote
  #2  
Old 02-24-2019, 10:56 AM
Junior Member
 
Join Date: Feb 2019
Location: Ph
Car: M3
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

unplugged your eccentric, see if it changes. THis is in your own risk. Do as you wish.

I fixed something like that issue, with different solutions.

1. replace eccentric drive (many times)
2. dme
3. throttle harness replacment
4. vacuum leak
5. Fuel pump
Reply With Quote
  #3  
Old 02-24-2019, 05:58 PM
Junior Member
 
Join Date: Feb 2019
Location: United Kingdom
Car: Bmw 320i E90
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have now replaced the injectors with index 11 and programmed them in.

still no change i then decided to unplug my vanos sensors and run the engine as a one off check, to my surprise the rough idle stopped and when putting full throttle on the car revs up as normal..

i then plugged the vanos back in and applied full throttle, my revs went back to bouncing and struggling to reach 3000 rpm

Unplugged them again and full throttle worked as normal.

so is it that the vanos solenoids are the problem or could it be something to do with what the vanos solenoids actually do to the cam shaft, as i know they move oil pressure around to move the cam shaft into advance position
Reply With Quote
  #4  
Old 02-25-2019, 12:53 PM
Junior Member
 
Join Date: Feb 2019
Location: United Kingdom
Car: Bmw 320i E90
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Removed vanos solenoids, hooked them up directly to car battery, both solenoids opened and closed.. so vanos seem to be working.

i placed them back in and again my engine revs up and down from 1000 rpm to 3000 rpm when keeping foot on throttle.

i removed the Camshaft Sensors and they where clogged up, so cleaned them down and placed them back in, no change... However if i unplug the top camshaft sensor the crazy reving on full throttle stops, and car revs normally.

Some people say it may be the eccentric shaft connector but i have no idea where that is..
Reply With Quote
  #5  
Old 02-26-2019, 10:00 AM
Junior Member
 
Join Date: Feb 2019
Location: United Kingdom
Car: Bmw 320i E90
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[Only for registered users... ]

I uploaded a video of my problem
Reply With Quote
  #6  
Old 03-02-2019, 04:17 PM
Junior Member
 
Join Date: Feb 2019
Location: United Kingdom
Car: Bmw 320i E90
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

If anyone is interested I found the problem

My cat had broke and blocked up the exhaust.. once replaced the car was fine.

I found this out by removing 1 of the o2 sensors from the exhaust to create a hole in the exhaust.. once I did this the car was able to rev..

I then took the exhaust system off and looked up the exhaust mainifold to see 1 of my cats broken inside
Reply With Quote
Reply

Tags
320i, low power, misfire

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear oxygen sensors disable E92/320i/N46 Jitter BMW coding and programming 1 01-18-2016 12:53 PM
What is need to code and erase errors on F30 320i 2013? propeople BMW coding and programming 5 10-21-2015 08:15 AM
Bmw 320i e90 lost key gora.aks BMW Programmers 0 09-06-2014 05:35 PM
How to Modify E36 320i 1998 RPM cluster to work on M60B40 V8 Engine?? Bahaa BMW coding and programming 1 06-06-2014 01:06 PM
Restraint system malfunction bmw 320i 2005 E90 please help lotto20m BMW diagnostics and repair 1 12-31-2013 06:17 AM


All times are GMT. The time now is 04:40 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.