BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-2016, 06:52 AM
Junior Member
 
Join Date: May 2016
Location: UK
Car: 2010 (60) BMW 520d SE
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default iDrive Random Language Change

I seem to be having an issue with my 2010 F10 520d SE where the language keeps changing on its own to German and then eventually back to English. I can start the car, the iDrive displays German menus, drive for 20-30 mins and it will change back to English (sometimes). This used to be every so often, but now its every time I start the car. When it is in German, the bluetooth phone connection doesn't work and the display for the parking sensors doesn't show, although it still beeps like normal and it won't let me manually change the language back via the settings menu. When it's in English (rarely), everything works fine.

This has really got me puzzled! It's got to be a software glitch, has anyone come across the same random behaviour? I really don't fancy having to pay BMW's diagnostic prices!

Note: I don't have the nav etc, it's just the basic small screen iDrive system, unsure of the abbreviation for the model.


Reply With Quote
  #2  
Old 09-13-2016, 04:47 PM
Junior Member
 
Join Date: Sep 2016
Location: Wales
Car: 520D (F10) 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem with my 520D - 2010 F10 model.

The language defaults to German after the car has been parked in sunshine, greater than say 20C/68F, or after a journey of 45 minutes or more. Also my radio reception degrades after driving for more than 45 minutes.

Have you figured out a solution yet?

Thanks
Reply With Quote
  #3  
Old 09-19-2018, 05:37 PM
Junior Member
 
Join Date: Sep 2018
Location: Dublin
Car: F10 520d
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Any update

Any success, Iím having the same issue.
Reply With Quote
  #4  
Old 03-29-2019, 07:47 AM
Junior Member
 
Join Date: Mar 2019
Location: Hawaii
Car: 2011 528i
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just had the same issue pop up on my 2011 today. Looks like it was caused by a week battery in my remote / key fob.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
F25 CIC language change racer9000 BMW ISIS, ICOM A+B+C, Esys 11 12-12-2018 07:19 PM
F10 CIC Language change Needanalias BMW ISIS, ICOM A+B+C, Esys 7 07-05-2018 02:22 AM
Change the language version zudong.xie New Members Area 3 10-31-2013 03:21 AM
iDrive language sekoyan BMW coding and programming 6 12-24-2012 03:48 AM
Change language idrive e61 eclipse45 BMW GT1, OPS/OPPS, INPA 4 07-12-2011 09:26 AM


All times are GMT. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.