BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW diagnostics and repair

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-26-2016, 11:34 PM
Junior Member
 
Join Date: Feb 2016
Location: Canada
Car: 335d, 530xit, m5
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Rhiengold ista communication problem to certain modules

Hello,

I have been using Rheingold for a while now, and every now and then it seem to not want to communicate with random modules. Although when I look at it on the Map view it sees it the modules and shows serial # and all that no problem.

But when I go into service function.....

For example, im trying to bleed my injectors on my 335d.

When i go to service function, then Engine, then DDE, then Bleeding fuel system, then ABL Bleeding, fuel system;
I get the message:

Communication problem with the following control unit:

-Electric fuel pump (EKP) control unit

Continue troubleshooting with following test module in testing schedule:

- Supply to fuel pump

I have a DCan cable $30 one, i tried to solder pins 7 and 8 together it did not help.

Any ideas??


Thank you


Reply With Quote
  #2  
Old 08-02-2016, 04:39 AM
Junior Member
 
Join Date: Nov 2014
Location: Oslo, Norway
Car: E60 520d
Posts: 11
Thanks: 0
Thanked 1 Time in 1 Post
Default

Most likely a bad cable.
Reply With Quote
  #3  
Old 08-06-2016, 07:42 PM
Junior Member
 
Join Date: Feb 2016
Location: Sweden
Car: BMW 525
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by SweetBMW View Post
Most likely a bad cable.
Yes probably. Get a proper K+DCAN cable OR ICOM made by a serious manufacturer. I payed like 40 EUR for my K+DCAN.

What chassis are you on? What version of data-files do you have installed? Upload a screenshot of your configuration or a log or something and I can take a look :)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with ICOM 1 and ISTA-D 3.49 / future2k1 BMW ISIS, ICOM A+B+C, Esys 0 07-13-2015 08:50 PM
ISTA/P voltage problem Kv8 BMW ISIS, ICOM A+B+C, Esys 1 09-29-2014 08:04 AM
ISTA-D Problem with Native Install cionide BMW ISIS, ICOM A+B+C, Esys 1 03-09-2014 10:02 AM
No communication with ECU victor247 BMW diagnostics and repair 0 09-06-2013 04:45 AM
strange problem ista d with dell d630 katy83 BMW ISIS, ICOM A+B+C, Esys 1 11-03-2012 11:27 AM


All times are GMT. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.