BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming > BMW GT1, OPS/OPPS, INPA

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-06-2015, 06:04 PM
Junior Member
 
Join Date: Aug 2014
Location: Orange County, CA
Car: '06 E53, '03 E46
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default INPA Errors, Need ABS Bleed Program

First off, thanks to everyone who has made this site so great. I have learned a lot here and have usually been able to find answers to my questions/issues through searching the threads. I am stuck on this one, though.

I am in the process of replacing my brake master cylinder on my X5 (2006 4.4i, E53) and want to bleed the ABS unit.

I was working with INPA 5.0.? and it was fully functional on my E46 for the past couple of years (it was also always in German, despite the UK install). However it had never been functional with my E53, it would always give me errors when trying to connect with the E53 module like "Requested control unit: 'ME9E65_6, ME9N62' not found. Control unit found: ME9N62_2. Program will be stopped!". The only thing I was ever able to do was use the E46 module on my E53 to read and clear codes, which has been sufficient up until now. After trying everything I could find on these boards I reinstalled INPA using these instructions:


Now, I am on INPA 5.0.2, and it looks and functions completely differently than before. First, it's in English (great!), Second, I can successfully connect to my E53 Engine group using the proper module, and it will show me all values, etc. that I ask for (awesome!). But, I cannot connect to the Chassis group, it gives me the error "Group file: D_ABSKWP. IFH-0009: No response from control unit. Program will be stopped!"


On the previous version of INPA I was using, within the "Special Programs" group there was a line for ABS Bleed (or something like that...I don't recall the exact wording). Now, that program does not exist in the Special Programs area. I never got that to work anyway, but that seemed to be an updated feature compared to the version I am using now...and, of course, that is ultimately what I am after for this particular round of work. I would gladly accept a fully functioning version of INPA without any issues, though!

My OBD plug is this one:



My Ediabas is this one (V7.2.0):


Here's a shot of INPA "About" on the current version I'm running:


Any instructions, links, or other guidance is greatly appreciated!

Last edited by crwarren11; 04-06-2015 at 10:30 PM.


Reply With Quote
  #2  
Old 09-26-2015, 10:01 PM
Junior Member
 
Join Date: Sep 2015
Location: UK
Car: E53
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Same problem

Hi,

I have same problems as you, did you get a solution to bleeding the ABS uint?

regards
Dave
Reply With Quote
  #3  
Old 02-29-2016, 07:05 PM
Junior Member
 
Join Date: Feb 2016
Location: NY
Car: BMW- 335I 6MT & 530Xi 6AT
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well first of all. you want to make sure INPA is working correctly. so connect to the air bag module under your correct chassis code and click rear error memory. if it reads the error memory properly that means the installation, settings, and cable are all working properly.

if it gives you an error. the first thing i would do is download an up to date DATEN file for your car (E53? I THINNK YOU SAID).

When it says it cannot or doesnt get a repsonse back from the ecu, theres ussually a problem with the hardware side of it (laptop/cable/install) or the DATEN files are incomplete and the ECU your trying to access isnt in the correct folder that INPA is looking for the file and how to talk to it and what settings and its not there...


if it does work. click on your chassis. go to chassi and go to dynamic stability control and read the error memory first to ensure a proper connection. if it all goes well, you would need to go to the ACTIVATE menu that is on the same screen as the rear error menu screen under INPA when you first get into the DSC ECU

Anthony
Reply With Quote
  #4  
Old 05-29-2018, 03:27 AM
Junior Member
 
Join Date: Mar 2018
Location: USA
Car: E53 (X5)
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Any updates?

I'm stuck with INPA unable to connect to a steering angle sensor ECU (DXC8). It gives an error:
Group code: D_ABSKWP
IFH-0009 No response from control module

It connects to airbags and seems like everything else just fine.

Any ideas? Thank you!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
SGM replaced, errors after flashing mclain BMW coding and programming 4 08-02-2016 04:19 AM
Errors - 5E3F and 5E50 dabhand BMW diagnostics and repair 3 10-18-2014 05:25 PM
WinKFP errors mwaku BMW coding and programming 1 08-12-2014 12:02 AM
Non starting E36 M43, INPA, no errors torq BMW GT1, OPS/OPPS, INPA 1 07-24-2013 03:52 PM
Errors with INPA on e46 ben m BMW diagnostics and repair 1 03-06-2013 12:03 AM


All times are GMT. The time now is 08:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.