BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming > BMW ISIS, ICOM A+B+C, Esys

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-24-2014, 06:47 PM
Junior Member
 
Join Date: Aug 2014
Location: UK
Car: F11 530D M sport
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default 6NR FSC coding failure.

Hello folks,

I purchased an FSC code for the 6NR option for my F11.

I've followed the following instructions :-

E-Sys => Options => Settings => FSC Tab => Certificate Field:

Load FSC Code Certificate (e.g. xxxxxxx_009C0001.der)

E-Sys => Comfort Mode => FSC => FSC Field:

Load FSC Code (e.g. xxxxxxx_009C0001.fsc. The FSC Code had to be Base 63 decoded first which I did as I got an error when trying to load it normally. )

This bit was a tad confusing..

FA Field: Select "Read FA" to use cars current VO.

All I had was an option to choose my FA, so I'd gone to coding read my FA, then saved it, and then selected my save FA

Diagnostic Address (hex) = 63
Application Number (dec) = 156
Base Variant = HU_CIC
Upgrade Index = 1 (In FSC File Name, e.g xxxxxxx_009C0001.fsc)

Selected "Upgrade FSC" to Import and Activate FSC Code.

But I got failure errors during the upgrade :-

--> TAL abgearbeitet <--
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<tal endTime="20140824-180948.464" startTime="20140824-180945.054" xmlns="http://bmw.com/2005/psdz.data.tal">
<ExecProperties supportsParallelMostFlash="false"/>
<talLine id="1">
<lineECU endTime="20140824-180948.454" startTime="20140824-180947.344" executionStatus="ProcessedWithError" baseVariant="HU_CIC" diagAddress="63">
<ecuTA>
<fscDeploy status="ProcessedWithError">
<fscDeployTA fscCert="xxxxxxxxxxxxxxxxxxx<-removed by me for sec reasons -> xxxxxxxxxxxxxxxxxxxxxxxxxxx" fsc=" xxxxxxxxxxxxxxxxxxx<-removed by me for sec reasons -> xxxxxxxxxxxxxxxxxxxxxxxxxxx" position="0" action="3" preHWDeinstall="false" endTime="20140824-180948.434" startTime="20140824-180947.574" breakpoint="false" status="ProcessedWithError">
<applicationID updateIndex="1" applicationNo="156"/>
<Exception timestamp="20140824-180948.424">
<MsgId>433</MsgId>
<MsgText>job failed with negative response error:
code: RoutineControl returned negative response
description: service Routine Control Verify FSC returned positive response with with result status = FSC_REJECTED; ECU: HU_CIC_63_ETHERNET
severity: ERROR
</MsgText>
<MsgArgs>
<MsgArg>negative response error:
code: RoutineControl returned negative response
description: service Routine Control Verify FSC returned positive response with with result status = FSC_REJECTED; ECU: HU_CIC_63_ETHERNET
severity: ERROR
</MsgArg>
</MsgArgs>
<PackageName>com.bmw.psdz.vehicle.connection.uti l</PackageName>
<ClassName>ResultUtil</ClassName>
<ExecutionContext>
<ContextCategory>TAL</ContextCategory>
<ecuID diagnosticAddress="99" baseVariantName="HU_CIC"/>
<ContextInfo>
<ContextItem value="1" key="TALLINE_ID"/>
</ContextInfo>
</ExecutionContext>
</Exception>
<WarnEvent timestamp="20140824-180948.034">
<MsgId>1631</MsgId>
<MsgText>executeFSCDeploy failed</MsgText>
<MsgArgs>
<MsgArg>ECUId:HU_CIC_0x63</MsgArg>
</MsgArgs>
<PSdZEventType>WARN</PSdZEventType>
<PackageName>com.bmw.psdz.programmer</PackageName>
<ClassName>ProgrammerImpl</ClassName>
</WarnEvent>
<WarnEvent timestamp="20140824-180948.424">
<MsgId>1631</MsgId>
<MsgText>executeFSCDeploy failed</MsgText>
<MsgArgs>
<MsgArg>ECUId:HU_CIC_0x63</MsgArg>
</MsgArgs>
<PSdZEventType>WARN</PSdZEventType>
<PackageName>com.bmw.psdz.programmer</PackageName>
<ClassName>ProgrammerImpl</ClassName>
</WarnEvent>
<MCDDiagServiceEvent timestamp="20140824-180948.034">
<MsgId>1685</MsgId>
<ecuID diagnosticAddress="99" baseVariantName="HU_CIC"/>
<PSdZEventType>DIAGSERVICE</PSdZEventType>
<PackageName>com.bmw.prodias.execution.primitives. mcd</PackageName>
<ClassName>SingleEcuJob</ClassName>
<MCDResponseType>POS_RESPONSE_WITH_NEG_CONTENT</MCDResponseType>
<JobName>com.bmw.psdz.jobs.uds.MCD3_SWTFullActivat e</JobName>
<ServiceName>RC_CFSC - RoutineControl FREISCHALTCODE_PRUEFEN</ServiceName>
<LinkName>HU_CIC_63_ETHERNET</LinkName>
<Description>error: positive response with negative content</Description>
<ErrorId>165200</ErrorId>
<ErrorName>error: positive response with negative content</ErrorName>
</MCDDiagServiceEvent>
<MCDDiagServiceEvent timestamp="20140824-180948.424">
<MsgId>1685</MsgId>
<ecuID diagnosticAddress="99" baseVariantName="HU_CIC"/>
<PSdZEventType>DIAGSERVICE</PSdZEventType>
<PackageName>com.bmw.prodias.execution.primitives. mcd</PackageName>
<ClassName>SingleEcuJob</ClassName>
<MCDResponseType>POS_RESPONSE_WITH_NEG_CONTENT</MCDResponseType>
<JobName>com.bmw.psdz.jobs.uds.MCD3_SWTFullActivat e</JobName>
<ServiceName>RC_CFSC - RoutineControl FREISCHALTCODE_PRUEFEN</ServiceName>
<LinkName>HU_CIC_63_ETHERNET</LinkName>
<Description>error: positive response with negative content</Description>
<ErrorId>165200</ErrorId>
<ErrorName>error: positive response with negative content</ErrorName>
</MCDDiagServiceEvent>
</fscDeployTA>
</fscDeploy>
</ecuTA>
</lineECU>
</talLine>
<executionTime actualEndTime="1408900188464" actualStartTime="1408900185054" plannedEndTime="1408900188464" plannedStartTime="1408900185054"/>
<installedECUList_Ist>
<ecuID diagnosticAddress="16" baseVariantName="ZGW"/>
<ecuID diagnosticAddress="24" baseVariantName="EGS"/>
<ecuID diagnosticAddress="48" baseVariantName="EPS"/>
<ecuID diagnosticAddress="96" baseVariantName="KOMBI"/>
<ecuID diagnosticAddress="2" baseVariantName="SZL_LWS"/>
<ecuID diagnosticAddress="0" baseVariantName="JBBF"/>
<ecuID diagnosticAddress="56" baseVariantName="EHC1"/>
<ecuID diagnosticAddress="103" baseVariantName="ZBE"/>
<ecuID diagnosticAddress="1" baseVariantName="ACSM"/>
<ecuID diagnosticAddress="86" baseVariantName="FZD"/>
<ecuID diagnosticAddress="18" baseVariantName="DME"/>
<ecuID diagnosticAddress="28" baseVariantName="ICM_QL"/>
<ecuID diagnosticAddress="99" baseVariantName="HU_CIC"/>
<ecuID diagnosticAddress="54" baseVariantName="CMB_MEDIA"/>
<ecuID diagnosticAddress="23" baseVariantName="EKPM"/>
<ecuID diagnosticAddress="94" baseVariantName="GWS"/>
<ecuID diagnosticAddress="115" baseVariantName="CID"/>
<ecuID diagnosticAddress="120" baseVariantName="IHKA"/>
<ecuID diagnosticAddress="64" baseVariantName="CAS"/>
<ecuID diagnosticAddress="42" baseVariantName="EMF"/>
<ecuID diagnosticAddress="41" baseVariantName="DSC"/>
<ecuID diagnosticAddress="13" baseVariantName="HKFM"/>
<ecuID diagnosticAddress="97" baseVariantName="CMB_ECALL"/>
<ecuID diagnosticAddress="100" baseVariantName="PDC"/>
<ecuID diagnosticAddress="114" baseVariantName="FRM"/>
</installedECUList_Ist>
<installedECUList_Soll>
<ecuID diagnosticAddress="16" baseVariantName="ZGW"/>
<ecuID diagnosticAddress="24" baseVariantName="EGS"/>
<ecuID diagnosticAddress="48" baseVariantName="EPS"/>
<ecuID diagnosticAddress="96" baseVariantName="KOMBI"/>
<ecuID diagnosticAddress="2" baseVariantName="SZL_LWS"/>
<ecuID diagnosticAddress="0" baseVariantName="JBBF"/>
<ecuID diagnosticAddress="56" baseVariantName="EHC1"/>
<ecuID diagnosticAddress="103" baseVariantName="ZBE"/>
<ecuID diagnosticAddress="1" baseVariantName="ACSM"/>
<ecuID diagnosticAddress="86" baseVariantName="FZD"/>
<ecuID diagnosticAddress="18" baseVariantName="DME"/>
<ecuID diagnosticAddress="28" baseVariantName="ICM_QL"/>
<ecuID diagnosticAddress="99" baseVariantName="HU_CIC"/>
<ecuID diagnosticAddress="54" baseVariantName="CMB_MEDIA"/>
<ecuID diagnosticAddress="23" baseVariantName="EKPM"/>
<ecuID diagnosticAddress="94" baseVariantName="GWS"/>
<ecuID diagnosticAddress="115" baseVariantName="CID"/>
<ecuID diagnosticAddress="120" baseVariantName="IHKA"/>
<ecuID diagnosticAddress="64" baseVariantName="CAS"/>
<ecuID diagnosticAddress="42" baseVariantName="EMF"/>
<ecuID diagnosticAddress="41" baseVariantName="DSC"/>
<ecuID diagnosticAddress="13" baseVariantName="HKFM"/>
<ecuID diagnosticAddress="97" baseVariantName="CMB_ECALL"/>
<ecuID diagnosticAddress="100" baseVariantName="PDC"/>
<ecuID diagnosticAddress="114" baseVariantName="FRM"/>
</installedECUList_Soll>
<TechnicalTALExecutionAction endTime="20140824-180947.264" startTime="20140824-180945.054" status="Processed" name="PrepareVehicle"/>
<TechnicalTALExecutionAction endTime="20140824-180947.284" startTime="20140824-180947.264" status="Processed" name="UpdateSvtSoll"/>
<TechnicalTALExecutionAction endTime="20140824-180948.454" startTime="20140824-180948.454" status="Processed" name="FinalizeVehicle"/>
<TechnicalTALExecutionAction endTime="20140824-180947.284" startTime="20140824-180947.284" status="Processed" name="PrepareVehicleFlash"/>
<TechnicalTALExecutionAction status="Executable" name="ActivateProgrammingMode"/>
<TechnicalTALExecutionAction endTime="20140824-180947.284" startTime="20140824-180947.284" status="Processed" name="FinalizeVehicleFlash"/>
<TechnicalTALExecutionAction status="Executable" name="DeactivateProgrammingMode"/>
<TechnicalTALExecutionAction endTime="20140824-180947.284" startTime="20140824-180947.284" status="Processed" name="PrepareVehicleCoding"/>
<TechnicalTALExecutionAction status="Executable" name="ActivateCodingMode"/>
<TechnicalTALExecutionAction endTime="20140824-180947.284" startTime="20140824-180947.284" status="Processed" name="FinalizeVehicleCoding"/>
<TechnicalTALExecutionAction status="Executable" name="DeactivateCodingMode"/>
<TechnicalTALExecutionAction endTime="20140824-180947.294" startTime="20140824-180947.294" status="Processed" name="PrepareVehicleFscDeploy"/>
<TechnicalTALExecutionAction endTime="20140824-180948.454" startTime="20140824-180948.454" status="Processed" name="FinalizeVehicleFscDeploy"/>
</tal>

And when I check the FSC status I see :-

AppID 156
UpgradeIndex 1
SWTType SWTclassic full
FSCStatus loaded
FSCCertStatus accepted

Anyone got any ideas ?? have I missed something dumb ?

Help appreciated.

Thanks Steve


Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
J2534 Pass Through BO failure LawJolla BMW coding and programming 2 08-19-2014 03:29 AM
330I SOS Failure - Coding bandsareme BMW coding and programming 0 03-07-2013 09:51 PM
E39/525d failure of several functions Willythecat BMW diagnostics and repair 0 01-27-2013 07:50 AM


All times are GMT. The time now is 07:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.