BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming > BMW ISIS, ICOM A+B+C, Esys

Like Tree1Likes
  • 1 Post By hmk
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-18-2015, 11:50 PM
hmk hmk is offline
Junior Member
 
Join Date: Nov 2015
Location: Romania
Car: X5 E53
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't get Rheingold to work with k+DCAN

Hi guys,

I'm new to all this programming stuff.
I recently bought a K+DCAN adapter and tried to run DIS with no luck.
I managed to run INPA and EDIABAS with both black dots on connection. My car is a E53. INPA doesn't work further, it returns all kinds of errors but I understand it doesn't work on this model. I didn't succeed in getting DIS to work either. It doesn't communicate with the cable. I tried DIAGHEAD and nothing. I tried all sorts off methods and read lots of forums. I rewritten registry's... nothing.

I gave up on DIS and found this Rheingold 3.43.50. I downloaded a stand alone copy and it starts up. I configured to work with EDIABAS. I upgraded EDIABAS to 7.3.0 and made all the settings COM 9, latency 1, STD:OBD, port 6801 but it Just WON't identify my car!

WTF IS GOING ON??? I'm getting mad! Can please someone help?
What am I doing wrong? Where do I start (again...)? But even if I get Rheingold to work, I understand it doesn't do coding... will I need DIS for coding new modules?

All this time INPA is showing me (almost like a joke) the two black dots which makes me think the cable and connection to the car is good.
mhgpinto likes this.


Reply With Quote
  #2  
Old 11-20-2015, 11:22 PM
Junior Member
 
Join Date: Nov 2015
Location: Brazil
Car: 2005 BMW X5 3.0i
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Hmy

I'm follow the same path. I bought a k+cam usb cable and awaiting to arrive. Install the Rheingold 3.41.10 but with licensing problems. My car is a X5 E53 as well. I think that we will exchange experiences from now on....

Can you please share with me your Rheingold 3.43.50 installation? It's important we stay at the same frame...

Thanks in advance.
Marcio Henrique
Reply With Quote
  #3  
Old 12-08-2015, 06:45 AM
Member
 
Join Date: Jul 2015
Location: L.A.
Car: BMW
Posts: 44
Thanks: 0
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by hmk View Post
Hi guys,

I'm new to all this programming stuff.
I recently bought a K+DCAN adapter and tried to run DIS with no luck.
I managed to run INPA and EDIABAS with both black dots on connection. My car is a E53. INPA doesn't work further, it returns all kinds of errors but I understand it doesn't work on this model. I didn't succeed in getting DIS to work either. It doesn't communicate with the cable. I tried DIAGHEAD and nothing. I tried all sorts off methods and read lots of forums. I rewritten registry's... nothing.

I gave up on DIS and found this Rheingold 3.43.50. I downloaded a stand alone copy and it starts up. I configured to work with EDIABAS. I upgraded EDIABAS to 7.3.0 and made all the settings COM 9, latency 1, STD:OBD, port 6801 but it Just WON't identify my car!

WTF IS GOING ON??? I'm getting mad! Can please someone help?
What am I doing wrong? Where do I start (again...)? But even if I get Rheingold to work, I understand it doesn't do coding... will I need DIS for coding new modules?

All this time INPA is showing me (almost like a joke) the two black dots which makes me think the cable and connection to the car is good.
hello, i guess you bought the low-quality K+DCAN cable. read this [Only for registered users... ]
Reply With Quote
  #4  
Old 12-08-2015, 10:42 PM
Junior Member
 
Join Date: Dec 2015
Location: London
Car: 320d E90 LCI
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Generally speaking if you have inpa connection, you should also have ista working on the same protocol.

Im not sure why you set com9, as with inpa I use com1 what is recommended.

Rheingold connects using ediabas OBD protocol which automatically runs in the background once you start rheingold.

Make sure that you change settings in Rheingold to ediabas OBD as standard connection setting in Rheingold is for ICOM connection.hope that helps
Reply With Quote
  #5  
Old 12-10-2015, 05:16 PM
Junior Member
 
Join Date: Apr 2015
Location: Eastern Canada
Car: E90 M3 and E39 touring
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

pretty sure you can't go higher than com 4 try to get your USB cable set to com 1
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
can pa soft work with K- Dcan cable iyad.nasser BMW Scanner (PASoft) 1 11-04-2015 06:01 AM
K+DCAN Cable Question rba BMW coding and programming 5 02-13-2015 07:43 AM
K-DCAN + INPA - e92 LCI -> Not working sinner- BMW coding and programming 1 12-21-2014 01:28 PM
ISTA/P with K+DCAN cable Kv8 BMW ISIS, ICOM A+B+C, Esys 4 09-14-2014 05:01 PM
PA 2.01 vs 2.20 K+DCAN TheEnd BMW Scanner (PASoft) 14 05-01-2013 01:10 PM


All times are GMT. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.