BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW coding and programming > BMW ISIS, ICOM A+B+C, Esys

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-25-2014, 08:14 PM
Junior Member
 
Join Date: Jun 2014
Location: Sweden
Car: F07
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Stuck E-SYS coding - need help!

Hello Guys!

I’m stuck coding - I need help!
I’ve got a BMW F07 530D built 2010-01 and retrofitted it with a M-sport paddle-shift steering wheel. My main objective with coding is to get paddle shifting working. Others have made the same move and made the paddles work by ESYS Coding: “SZL->3000->Lenkrad_ShaftPaddles->Aktive”(default "not Aktive").

So I bought a Chinese cable with E-Sys 3.23.4 on Ebay and installed it. It said the token was out of date, but I got it working by changing the date in my laptop.

I've coded “SZL->3000->Lenkrad_ShaftPaddles->Aktive”, following some YouTube DIY guide-line, but no result at all.

I've tried the “Cheat Sheet F10" instructions (By following “FA(VO) Step-By-Step (MWPos) 8-24-2013”);FA (VO) Replace 205 with 2TB. Code new FA in ECUs ICM, EGS, GWS, and SZL

The strange thing is that “205” does not appear in my SALPA list, though it’s listed in Vehicle Profile under Gearbox (?!?). If I add 2TB, I’ll get both “205” Gearbox and “2TB” in the Vehicle Profile…

However, I do get error messages when coding:
TAL execution started. [C205]
[MULF - 55] Could not read ComParam 'IS_FLEXRAY_ISOTP'. Maybe the template is to old.
[MULF - 55] Could not read ComParam 'IS_FLEXRAY_ISOTP'. Maybe the template is to old.
[TEL - 36] Could not read ComParam 'IS_FLEXRAY_ISOTP'. Maybe the template is to old.
[TEL - 36] Could not read ComParam 'IS_FLEXRAY_ISOTP'. Maybe the template is to old.

Any tips what do to is appreciated!

Best Regards,

Rikard


Reply With Quote
  #2  
Old 11-13-2014, 03:37 PM
Junior Member
 
Join Date: Jun 2014
Location: Sweden
Car: F07
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello Again!

Some progress. I got the coding up and running. A new copy of E-Sys and token solved my issues with error messages so now I managed to Code some good stuff!

However, no progress with getting the paddles to work. I tried:

SZL->3000->Lenkrad_ShaftPaddles->Aktive”(default "not Aktive") - nothing.

and (my own idea after fiddeling around):

EGS ->3000->Sportschalter->Aktive”(default "not Aktive") - still nothing.

I found this thread: [Only for registered users... ]

F07 shares alot with F01, so now I wondering if a need a new steering cluster to make it work?

Any clue what to do?

Best Regards,

Rikard
Reply With Quote
  #3  
Old 12-22-2014, 01:04 PM
Junior Member
 
Join Date: Aug 2012
Location: UK
Car: 750
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

2TB it sport gearbox you can add to VO too but not necessary
But easy way to get steering wheel working is add steering wheel with paddles $7XA to VO
I had $710 so I deleated and added $7XA coded EGS ICM and SZL
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CIC stuck in bootloader mode Tpudel BMW coding and programming 21 02-24-2019 05:11 PM


All times are GMT. The time now is 01:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.