BMW ICOM NEXT | BMW NBT EVO FSC Codes | BMW NBT & CIC FSC Codes | BMW Rheingold , ISTA/P, KSD, ETK remote installation | BMW STANDARD TOOLS remote installation | BMW ESYS remote installation
Go Back   BMW forum. Diagnostics, coding, programming, repair BMW vehicles. > BMWelcome > BMW Programmers

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-01-2014, 11:34 PM
Junior Member
 
Join Date: Mar 2014
Location: Ireland
Car: BMW E60
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default SOLVED! Problem after replacing cas-dme-key

Hi all, hope someone can help me here, I recently posted this on a BMW forum and someone suggested to try here as my problem seems to be related to programming. My problem is I recently had water damage to my dme and due to corrosion some of my pins are missing so I took what I thought was the easy option and changed the dme with the dme out of a crashed vehicle identical to mine which is an e60 520i year 2004 I also bought the cas and key from the same vehicle. After installation and a new plug and wiring to replace corroded ones the car starts and runs fine but I was left with two warning lights 1/DCS and 2/Airbag, after running diagnostics with INPA I found out it was related to the steering angle sensor having the wrong vin so I eventually changed the vin on the SLZ with WINKFP to match the vin of the new dme and cas and I was able to reset the steering angle sensor which got rid of the DSC warning light, so now I am left with the Airbag warning light, and according to INPA is due to a system timing error which I tried to reset with tool 32 and DIS but with no luck, I think it maybe due to the fact that the KOMBI has a different VIN but I am not sure, if that is the case I will try and buy the KOMBI out of the donor car if still available and if not maybe change the M35080 chip in my current KOMBI, if there is a way anybody knows of resetting the system time errors without doing this I would appreciate your help or better again changing the vin on the cas and dme to match the rest of the car and be able to start with same key ....Thanks

Last edited by mb67; 12-19-2014 at 10:15 PM. Reason: Problem Solved


Reply With Quote
  #2  
Old 06-13-2014, 12:12 PM
Junior Member
 
Join Date: Sep 2012
Location: NY
Car: Bmw
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi I'm in a similar situation I recently did a motor swap m3 motor dme cas and key I have a no start situation because of programming issue I have being asking around most of the BMW forums for help for months no luck so far.

I know that EPROM chip in kombi is read only. You need to replace the chip and code it to match your current vin.
Reply With Quote
  #3  
Old 12-19-2014, 10:12 PM
Junior Member
 
Join Date: Mar 2014
Location: Ireland
Car: BMW E60
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default SOLVED Problem after replacing cas-dme-key

Just an update to let you know how it finished up, I was having problems finding someone over here to replace the socket on my original DME so as it was getting close to my cars national test I was running out of time and the car would not pass with an airbag light on the dash, so I tried to reset the system time again with DIS but with no luck as all modules were not with matching VIN's so I tried again with tool 32 but it would say ECU conditions not correct, grasping at straws I thought I'd check that the SIM and all safety modules matched with the VIN of the new CAS and DME which they did as I had updated them to the new VIN with winkfp. After that I opened up NCS expert and wrote down the letter showing at the end of the VIN and went back to tool32 and even though I wrote the new VIN to all the modules with winkfp the last letter you see in NCS expert was not wrote so I re-wrote the new VIN with the letter at the end with tool 32, I tried starting the system time again with tool 32 using the argument number 1 on each module separately starting with the SIM module first and to my delight all worked fine so no airbag light anymore.... Thanks to all for your input, I will probably get the original DME repaired with a new socket eventually but car is running fine with absolutely no warning messages so no hurry anymore.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
help in replacing ecu bachirnassif BMW coding and programming 2 01-14-2014 03:55 PM
replacing a damaged ECU with a used one bachirnassif BMW coding and programming 4 10-23-2013 08:03 AM
mileage remains zero after replacing an Instrument Cluster on BMW X5 DKISSOONDOYAL BMW coding and programming 1 07-16-2013 03:13 PM
F30 - Replacing CiC with Head Unit high tomtom BMW coding and programming 3 05-30-2013 09:31 AM
Programming after replacing component moe325 BMW GT1, OPS/OPPS, INPA 0 01-30-2012 12:33 PM


All times are GMT. The time now is 10:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
BMW forum: diagnostics, coding, programming.